Performance Boats Forum banner
1 - 10 of 10 Posts

·
Premium Member
Joined
·
1,432 Posts
Discussion Starter · #1 ·
I'm runnin a magnaflow water pump on the hydro, 392 chrysler hemi, pick up tube is the rudder, it keeps blowin one freeze plug out, should I have a valve on the inlet or what??????????
 

·
Registered
Joined
·
2,469 Posts
We ran that same setup on our Hydro..Check the impeller before you do anything else to it.. Force feeding the pump seemed to abuse the impeller abit..If it's broken a vain or two off it may cause it to pulse the pressure in the block...And be sure the freeze plugs are good ones & installed/fit properly.. Also check the water dump as it may have a restriction somewhere..
 

·
Premium Member
Joined
·
1,432 Posts
Discussion Starter · #3 ·
just put a new impeler in it, will check for a restriction in the outlet, is it possible because of the speed of the boat its building too much pressure
 

·
Registered
Joined
·
2,469 Posts
Our boat ran 120 and change & never had this issue...could be a block defect that's not allowing the freeze plug to seat properly..
 

·
Premium Member
Joined
·
1,432 Posts
Discussion Starter · #5 ·
the hemis have those stupid disc typle freeze plugs and the block has been filled to the bottom of the freeze plugs, but I am going to check for a restriction
 

·
Purple headed member
Joined
·
7,646 Posts
the hemis have those stupid disc typle freeze plugs and the block has been filled to the bottom of the freeze plugs, but I am going to check for a restriction
Take the impeller out and cut off every other blade then re-install it Should solve the problem. And at 120mph the impeller is a restriction more than anything else.
 

·
Registered
Joined
·
17 Posts
Put a gauge on the engine to check pressure. Before you try to fix a hich pressure problem make sure it is. 15 PSI is good 45 PSI is BAD.
 

·
Premium Member
Joined
·
1,432 Posts
Discussion Starter · #8 ·
Put a gauge on the engine to check pressure. Before you try to fix a hich pressure problem make sure it is. 15 PSI is good 45 PSI is BAD.
good idea, I think I'll cut every other one of and install a gauge, should I also install a ball type valve??
 

·
Registered
Joined
·
31 Posts
hyroman,
i run the same set-up,1 with a 392 & 1 with a 454 in a hydro with the pick-up off the rudder & it works fine. we use 5/8 o.d. stianless tube with #10 hose going to a mike kuhl pmp.with alcohol it works too good because i can't get enough heat in the motor. hopefully this helps. good luck.
 
1 - 10 of 10 Posts
Top