57 MPH @ 5100 RPM ( what gives) ???????
+ Reply to Thread
Results 1 to 3 of 3

Thread:
57 MPH @ 5100 RPM ( what gives) ???????

  1. #1
    Member
    Join Date
    Jan 2012
    Location
    Independence KS
    Posts
    95

    Default 57 MPH @ 5100 RPM ( what gives) ???????

    Low Down

    1986 TX-19 with Fresh 461 BBC. Motor man says motor is 9.5:1 pushing around 450 ponys. Have a standard 1310 H-bar/driveline from Tom at JBP.

    Pump is a Dom 12-S split bowl. Impellar is unkown. NO loader, shoe, or Droop not even a rock grate( I Know). Has a ride Plate and new Place diverter. Pump is set back I think. Inspection cover splits the the transom about 50%. Pretty sure it needs rebuilt but noting was loose when i bought it and makes no noise when im driving. Ive been told by Tom this config should be running 70 with 4 grown adults. I belive its a light lay up boat. 3/4'' stringers when i bought it. One man can easly lift off trailor when empty pump out of course. What do i need to do to get this boat running like it should. From some of the video of my boat it seams to ride wet.

  2. Remove Advertisements
    PerformanceBoats.com
    Advertisements
     

  3. #2
    "Need For Speed" Gearhead's Avatar
    Join Date
    Jan 2008
    Location
    Atlanta, Texas, United States
    Posts
    1,210

    Default

    Quote Originally Posted by KansasJet View Post
    Low Down

    1986 TX-19 with Fresh 461 BBC. Motor man says motor is 9.5:1 pushing around 450 ponys. Have a standard 1310 H-bar/driveline from Tom at JBP.

    Pump is a Dom 12-S split bowl. Impellar is unkown. NO loader, shoe, or Droop not even a rock grate( I Know). Has a ride Plate and new Place diverter. Pump is set back I think. Inspection cover splits the the transom about 50%. Pretty sure it needs rebuilt but noting was loose when i bought it and makes no noise when im driving. Ive been told by Tom this config should be running 70 with 4 grown adults. I belive its a light lay up boat. 3/4'' stringers when i bought it. One man can easly lift off trailor when empty pump out of course. What do i need to do to get this boat running like it should. From some of the video of my boat it seams to ride wet.
    KJ,

    Without getting into a long detailed conversation, as seeing with eyes may be much better than words, you might consider pulling the boat down to Hot Springs to Tigertooth's shop. Since you are heading there anyway, he could probably keep it in his fence and could look at the boat real quick and tell you what is going on.

    Gear
    Last edited by Gearhead; 08-24-2012 at 06:05 PM.

  4. #3
    Senior Member TNYoungblood's Avatar
    Join Date
    Mar 2010
    Location
    Clarksville, TN
    Posts
    5,102

    Default

    Ya gotta get a loader. Most of us run 1 from MPD. That will help. Your in about the same boat Nerve Damage is in. Read that Ride plate angle thread and do about the same. With ur HP 70 mph shouldn't be hard to get.

    And ur pump is in a stock location for a GW
    Last edited by TNYoungblood; 08-25-2012 at 08:08 AM.
    WFLC The REAL #321 Kentucky Drag Boat Association 2016 NJBA 10.0 High Points Champ

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

Please select your insurance company (Optional)

Log-in

Tags for this Thread

Digg This Thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •  
 

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95